Not sending characters specific to czech language

Post Reply
Elmar.el
Posts: 1
Joined: 2020-11-05 11:16

Not sending characters specific to czech language

Post by Elmar.el »

Hi, when I use uVNC, on the target computer I cannot write characters like ě (https://en.wikipedia.org/wiki/%C4%9A) ř (https://en.wikipedia.org/wiki/%C5%98) and some other characters with diacritic.
Is there any way to write it properly?
Thanks.
Lucent
8
8
Posts: 30
Joined: 2018-08-27 12:33

Re: Not sending characters specific to czech language

Post by Lucent »

Try with this server options disabled
[ ] Alternate Keyboard
[ ] International Keys
[ ] Win8 KeyboardHelper
eliotcougar
8
8
Posts: 11
Joined: 2020-12-13 13:25

Re: Not sending characters specific to czech language

Post by eliotcougar »

It has been like that for as long as I know VNC...
I don't know how exactly VNC sends keystrokes, but it is not very compatible with any non-English environments...
For example, I have two machines with English and Russian keyboard layouts... If both Server and Client have English currently selected, everything is fine... If I simply press Ctrl+Shift to switch the layouts on both machines simultaneously, I can't write in Russian - some Arabic garbage appears in text fields instead... I can write in Russian only if I manually switch to Russian on the Server side, and keep English on the client side... Even then I have issues sometimes if the server runs on a laptop - you press a specific key, but on the laptop it may be something completely different - forward and backslashes, tilda, sometimes even comma and period are screwed... (that's when I do remote tech-support using VNC SC viewer version 1.1.9.5)

Usually I end up simply opening the on-screen keyboard in Windows 10 if I need to type something...
Jux
Posts: 1
Joined: 2020-11-04 16:20

Re: Not sending characters specific to czech language

Post by Jux »

Hi, is there anything new in solving this problem ? I use UltraVNC very often, and it bothers me a lot that this otherwise so good program doesn't transfer the characters š, ž, ó from the Czech keyboard and also doesn't respond when typing on the CAPS LOCK key. I have tried the settings by [Lucent], but it has no effect on the problem. :cry:
justanITguy
Posts: 1
Joined: 2022-03-28 19:46

Re: Not sending characters specific to czech language

Post by justanITguy »

at first I want to say thanks! to developers team for their hard work and great software

I began to use UltraVNC for a few days, and faced the same problem that eliotcougar described.

my setup is a pair of computers, both with Win10
UltraVNC 1.3.81 (actual)

my computer-server contains two keyboard layouts - english, russian
my computer-client contains three keyboard layouts - ukrainian, english, russian

keyboard layout is switched via Ctrl-Shift combo

due to difference between computers keyboards layout configuration there is problematic to type text
at computer-server when I switch layout here ( after switching symbols are not appeared when I press buttons)
this is ... frustrating a bit, and infuriating same time :-)

I looked through some internet forums etc and for the moment the most helpful and useful solution
is to turn on ScrollLock after connection established between client and server

I mean
(1) connect to server
(2) press ScrollLock

after ScrollLock is pressed I noticed the keyboard layout is switched just at server.
I mean when I connected to server, and server desktop window is in focus, and I switch the
keyboard layout - it switched just at server, it is not switched at computer-client.
And I can input text on various languages correctly on computer-server.

the only precaution - after all is working stable and as you wish - avoid to switch layout at computer-client, in my case this "break" all the scheme and I have to "resync" layouts on both computers again

I tried to add czech layout to my computer-server
so now there is three layouts on server - english, russian, czech

I tried to type text on all three languages at notepad, in my case these czech special symbols
I can type correctly(these symbols are situated at upper number keys, aren't they? I just found them with help of visual keyboard)

well, chances are there are lot of special features and nuances - I just use this software literally a few days, so don't know much

sorry for my English, it's not my native, and not so nice as I wish :-)
Post Reply