New server by newbie doesn't respond

Here you will find help for frequently asked questions as well as for your specific question.
Post Reply
User avatar
WillPittenger
Posts: 2
Joined: 2022-05-09 20:29

New server by newbie doesn't respond

Post by WillPittenger »

I've used the TightVNC client before. However, I just installed UltraVNC on two different PCs. I set up the server and then tried to get the client going on a different PC. I know the client PC can see the see the server PC as File Explorer can access the files in my shares. However, the UltraVNC client times out. Can someone help me figure out what's wrong?

Below are my settings from both PCs.
  • 10.1.10.246-5900.vnc on client PC

    Code: Select all

    [connection]
    host=10.1.10.246
    port=5900
    proxyhost=
    proxyport=0
    [options]
    use_encoding_0=1
    use_encoding_1=1
    use_encoding_2=1
    use_encoding_3=0
    use_encoding_4=1
    use_encoding_5=1
    use_encoding_6=1
    use_encoding_7=1
    use_encoding_8=1
    use_encoding_9=1
    use_encoding_10=1
    use_encoding_11=0
    use_encoding_12=0
    use_encoding_13=0
    use_encoding_14=0
    use_encoding_15=0
    use_encoding_16=1
    use_encoding_17=1
    use_encoding_18=1
    use_encoding_19=1
    use_encoding_20=0
    use_encoding_21=0
    use_encoding_22=0
    use_encoding_23=0
    use_encoding_24=0
    use_encoding_25=1
    use_encoding_26=1
    use_encoding_27=1
    use_encoding_28=0
    use_encoding_29=1
    preferred_encoding=6
    viewonly=0
    showtoolbar=1
    fullscreen=0
    SavePos=1
    SaveSize=1
    directx=1
    autoDetect=0
    8bit=0
    shared=1
    swapmouse=0
    emulate3=1
    JapKeyboard=0
    disableclipboard=0
    Scaling=0
    AutoScaling=0
    AutoScalingEven=0
    AutoScalingLimit=0
    scale_num=1
    scale_den=1
    cursorshape=1
    noremotecursor=0
    compresslevel=6
    quality=8
    ServerScale=1
    Reconnect=3
    EnableCache=1
    EnableZstd=1
    QuickOption=1
    UseDSMPlugin=0
    UseProxy=0
    allowMonitorSpanning=0
    ChangeServerRes=0
    extendDisplay=0
    showExtend=0
    use_virt=0
    useAllMonitors=0
    requestedWidth=0
    requestedHeight=0
    DSMPlugin=SecureVNCPlugin64.dsm
    folder=C:\Users\Will Pittenger\Documents\UltraVNC
    prefix=vnc_
    imageFormat=.jpeg
    InfoMsg=
    AutoReconnect=3
    FileTransferTimeout=30
    ThrottleMouse=0
    KeepAliveInterval=5
    AutoAcceptIncoming=0
    AutoAcceptNoDSM=0
    GiiEnable=0
    RequireEncryption=0
    restricted=0
    AllowUntrustedServers=0
    nostatus=0
    nohotkeys=0
    sponsor=1
    PreemptiveUpdates=0
    
  • options.vnc on client PC

    Code: Select all

    [connection]
    index=AB
    A=10.1.10.246:5900
    B=10.1.10.246:5800
    
  • UltraVNC.ini on server

    Code: Select all

    [admin]
    UseRegistry=0
    SendExtraMouse=1
    Secure=0
    MSLogonRequired=1
    NewMSLogon=0
    ReverseAuthRequired=1
    DebugMode=0
    Avilog=0
    path=C:\Program Files\uvnc bvba\UltraVnc
    accept_reject_mesg=
    DebugLevel=0
    DisableTrayIcon=0
    rdpmode=0
    noscreensaver=0
    LoopbackOnly=0
    UseDSMPlugin=0
    AllowLoopback=0
    AuthRequired=1
    ConnectPriority=1
    DSMPlugin=SecureVNCPlugin64.dsm
    AuthHosts=
    DSMPluginConfig=
    AllowShutdown=1
    AllowProperties=1
    AllowInjection=0
    AllowEditClients=1
    FileTransferEnabled=1
    FTUserImpersonation=1
    BlankMonitorEnabled=1
    BlankInputsOnly=0
    DefaultScale=1
    primary=1
    secondary=0
    SocketConnect=1
    HTTPConnect=1
    AutoPortSelect=1
    PortNumber=5900
    HTTPPortNumber=5800
    IdleTimeout=0
    IdleInputTimeout=0
    RemoveWallpaper=0
    QuerySetting=2
    QueryTimeout=10
    QueryDisableTime=0
    QueryAccept=0
    QueryIfNoLogon=1
    MaxViewerSetting=0
    Collabo=0
    Frame=0
    Notification=0
    NotificationSelection=0
    MaxViewers=128
    InputsEnabled=1
    LockSetting=0
    LocalInputsDisabled=0
    EnableJapInput=0
    EnableUnicodeInput=0
    EnableWin8Helper=0
    kickrdp=0
    clearconsole=0
    [admin_auth]
    group1=Users
    group2=Administrators
    group3=
    locdom1=1
    locdom2=1
    locdom3=0
    [UltraVNC]
    passwd=******************
    passwd2=******************
    [poll]
    TurboMode=1
    PollUnderCursor=0
    PollForeground=0
    PollFullScreen=1
    OnlyPollConsole=0
    OnlyPollOnEvent=0
    MaxCpu2=100
    MaxFPS=25
    EnableDriver=0
    EnableHook=1
    EnableVirtual=0
    SingleWindow=0
    SingleWindowName=
    
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6486
Joined: 2004-04-23 10:21
Contact:

Re: New server by newbie doesn't respond

Post by Rudi De Vos »

What you can test.
1) A Tightvnc server/viewer with a UltraVNC server/viewer. you can interchange them
2) Try to run the viewer on the pc running the sever, with connection to localhost:5900
-This should always work, this eliminate all server/viewer firewall settings and other security
-Try with vnc password first. If that works use mslogon.
-You are using the plugin SecureVNCPlugin64.dsm , does the viewer also have the encryption plugin enabled ?
Try without first

3) Try to run the viewer from another PC, test with firewall disabled, if that works add the rules for tcp 5900
User avatar
WillPittenger
Posts: 2
Joined: 2022-05-09 20:29

Re: New server by newbie doesn't respond

Post by WillPittenger »

Hmm. I thought UltraVNC creates firewall rules during installation. I'm not seeing them. That seems to be the problem. Once a rule was created, I was able to connect. However, I do see some issues:
  1. It warned me that things were being sent unencrypted even those encryption was on as I was about to connect.
  2. The screen keeps blanking after just a few seconds. No screen saver is active on the remote machine and screen blanking is disabled there.
  3. Not very responsive.
  4. It's hard to Alt-tab between windows on the remote machine as Windows on the local machine keeps grabbing the key. So some means of sending Alt-Tab quickly is needed.
  5. When the client is maximized, many toolbar functions are unavailable and the client seems to be always on top. The latter makes it tough to access other windows on the local machine.
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6486
Joined: 2004-04-23 10:21
Contact:

Re: New server by newbie doesn't respond

Post by Rudi De Vos »

Yes the installer create firewall rules.

Code: Select all

Filename: "{sys}\netsh"; Parameters: "firewall add portopening TCP 5900 vnc5900"; Flags: runhidden; StatusMsg: "{cm:firewall}"; MinVersion: 0,5.01; Components: UltraVNC_Server 
Filename: "{sys}\netsh"; Parameters: "firewall add portopening TCP 5800 vnc5800"; Flags: runhidden; StatusMsg: "{cm:firewall}"; MinVersion: 0,5.01; Components: UltraVNC_Server 
Filename: "{sys}\netsh"; Parameters: "firewall add allowedprogram ""{app}\winvnc.exe"" ""winvnc.exe"" ENABLE ALL"; Flags: runhidden; StatusMsg: "{cm:firewall}"; MinVersion: 0,5.01; Components: UltraVNC_Server 
Filename: "{sys}\netsh"; Parameters: "firewall add allowedprogram ""{app}\vncviewer.exe"" ""vncviewer.exe"" ENABLE ALL"; Flags: runhidden; StatusMsg: "{cm:firewall}"; MinVersion: 0,5.01; Components: UltraVNC_Viewer
1) Viewer has encryption on, but server not . Then the viewer can switch to plain mode.
2) No idea what happen
3) Strange, we normal get 25fps with a HD screen and latency is acceptable. ( tests on a old i7 intel)
Unless heavy compressors like zrle are used, tests are done with the video encoder. (u2)
4) Scroll lock on on send special window keys to the remote
5) The buttons were removed in fullscreen
Fit to screen with buttons the height/width are proper scaled 100/100
A fullscreen without, this was done to avoid having a bad scaling and screen deformation 98/100

For testing we don't set any setting. The defaults should be ok in most cases.

Running as service ? application
OS, video card
Post Reply