Error in VNCViewer after ver.1.3.6.0

Single Click discussions / bugs
Post Reply
upotrebitel
Posts: 6
Joined: 2022-04-22 02:23

Error in VNCViewer after ver.1.3.6.0

Post by upotrebitel »

Hi!

I use UltraVNC in Single Click mode, starting on client side:

winvnc.exe -sc_prompt -autoreconnect -connect xxx.xxx.xxx.xxx.:XXXX -run

On my machine I run:

vncviewer.exe -listen XXXX

But after version 1.3.6.0 when I start "vncviewer.exe", it's open a hundreds windows with error for rejected connection. On version 1.3.6.0 and earlier versions it's work fine. After a lot of experiments I found that removing option "-sc_prompt" from command line of "winvnc.exe" solve the problem and connection is estabilished with new "vncviewer.exe" v.1.3.8.1.

The problem is that I have a lot of machines, that run winvnc with option "-sc_prompt" and I can't use newer viewer. So, can you fix this bug in next version ot UltraVNC, please?
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6508
Joined: 2004-04-23 10:21
Contact:

Re: Error in VNCViewer after ver.1.3.6.0

Post by Rudi De Vos »

What's the error you get.
Is the password on the server set, or you just run without a ini file.

If the password is the cause.
You can disable by unchecking
Viewer 1.3.8.1
[v] only server with password
upotrebitel
Posts: 6
Joined: 2022-04-22 02:23

Re: Error in VNCViewer after ver.1.3.6.0

Post by upotrebitel »

Error is: "Your connection has been rejected".

I have "WinVNC.ini" file and file "SecureVNCPlugin64.dsm" in the same folder with "winvnc.exe".

Code: Select all

[ultravnc]
passwd=123456
passwd2=654321
[admin]
DSMPluginConfig=SecureVNC;0;0x00148004;
UseRegistry=0
MSLogonRequired=0
NewMSLogon=0
DebugMode=2
Avilog=0
path=.
kickrdp=0
service_commandline=
DebugLevel=10
DisableTrayIcon=0
rdpmode=0
LoopbackOnly=0
UseDSMPlugin=1
AllowLoopback=1
AuthRequired=0
ConnectPriority=0
DSMPlugin=SecureVNCPlugin64.dsm
AuthHosts=
AllowShutdown=1
AllowProperties=1
AllowEditClients=1
FileTransferEnabled=1
FTUserImpersonation=1
BlankMonitorEnabled=1
BlankInputsOnly=0
DefaultScale=1
SocketConnect=1
HTTPConnect=1
AutoPortSelect=1
PortNumber=5900
HTTPPortNumber=5800
IdleTimeout=0
IdleInputTimeout=0
RemoveWallpaper=0
RemoveAero=0
QuerySetting=1
QueryTimeout=10
QueryAccept=0
QueryIfNoLogon=0
primary=1
secondary=0
InputsEnabled=1
LockSetting=0
LocalInputsDisabled=0
EnableJapInput=0
FileTransferTimeout=1
clearconsole=0
accept_reject_mesg=
KeepAliveInterval=5
[poll]
TurboMode=1
PollUnderCursor=0
PollForeground=0
PollFullScreen=1
OnlyPollConsole=0
OnlyPollOnEvent=0
EnableDriver=0
EnableHook=1
EnableVirtual=0
SingleWindow=0
SingleWindowName=
MaxCpu2=100
MaxFPS=25
One of the first things that I do is to uncheck "[ ] only server with password" in "vncviewer.exe". My file "options.vnc" in the same folder with "vncviewer.exe" is:

Code: Select all

[connection]
host=
port=5900
proxyhost=
proxyport=0
index=
[options]
use_encoding_0=1
use_encoding_1=1
use_encoding_2=1
use_encoding_3=0
use_encoding_4=1
use_encoding_5=1
use_encoding_6=1
use_encoding_7=1
use_encoding_8=1
use_encoding_9=1
use_encoding_10=1
use_encoding_11=0
use_encoding_12=0
use_encoding_13=0
use_encoding_14=0
use_encoding_15=0
use_encoding_16=1
use_encoding_17=1
use_encoding_18=1
use_encoding_19=1
use_encoding_20=0
use_encoding_21=0
use_encoding_22=0
use_encoding_23=0
use_encoding_24=0
use_encoding_25=1
use_encoding_26=1
use_encoding_27=1
use_encoding_28=0
use_encoding_29=1
preferred_encoding=10
viewonly=0
showtoolbar=1
fullscreen=0
SavePos=0
SaveSize=0
directx=1
autoDetect=0
8bit=0
shared=1
swapmouse=0
emulate3=1
JapKeyboard=0
disableclipboard=0
Scaling=0
AutoScaling=0
AutoScalingEven=0
AutoScalingLimit=0
scale_num=1
scale_den=1
cursorshape=1
noremotecursor=0
compresslevel=6
quality=8
ServerScale=1
Reconnect=3
EnableCache=0
EnableZstd=1
QuickOption=1
UseDSMPlugin=1
UseProxy=0
allowMonitorSpanning=0
ChangeServerRes=0
extendDisplay=0
showExtend=0
use_virt=0
useAllMonitors=0
requestedWidth=0
requestedHeight=0
DSMPlugin=SecureVNCPlugin64.dsm
folder=.
prefix=vnc_
imageFormat=.jpeg
AutoReconnect=3
FileTransferTimeout=30
ThrottleMouse=0
KeepAliveInterval=5
AutoAcceptIncoming=0
AutoAcceptNoDSM=0
GiiEnable=0
RequireEncryption=0
restricted=0
nostatus=0
nohotkeys=0
sponsor=1
PreemptiveUpdates=0
belldeiconify=0
BlockSameMouse=0
emulate3timeout=100
emulate3fuzz=4
localcursor=1
use_allmonitors=0
ExitCheck=0
ListenPort=
InfoMsg=
AllowUntrustedServers=1
The result is the same - hundreds windows with error message "Your connection has been rejected" apperas. But when I remove option "-sc_prompt" from "winvnc.exe" command line, it's work fine!
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6508
Joined: 2004-04-23 10:21
Contact:

Re: Error in VNCViewer after ver.1.3.6.0

Post by Rudi De Vos »

Just tried it with your ini and option.vnc file ... and have the same as you.
Some combination of options seems to trigger it.
upotrebitel
Posts: 6
Joined: 2022-04-22 02:23

Re: Error in VNCViewer after ver.1.3.6.0

Post by upotrebitel »

Yes, new "winvnc.exe" 1.3.9.0 work fine with "vncviewer.exe" v.1.3.8.1 and my config files. Thank you very much!

But I hope that you can make new version of "vncviewer.exe", that work with all versions of "winvnc.exe". Because I have a lot of clients, that runs older versions of "winvnc.exe" and the error appears when I run on my computer new "vncviewer.exe", after version 1.3.6.0.
VNCHELP890
20
20
Posts: 32
Joined: 2022-01-18 16:46

Re: Error in VNCViewer after ver.1.3.6.0

Post by VNCHELP890 »

Rudi De Vos wrote: 2022-04-24 18:28 winvnc.exe 32/64 bit

https://www.uvnc.eu/download/1390/winvnc_139dev1.zip
Is this an all new "dev build", beyond version 1.3.8.1?

If so, it might be time to create a new area in the "Version-specific help" area.

Thanks.
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6508
Joined: 2004-04-23 10:21
Contact:

Re: Error in VNCViewer after ver.1.3.6.0

Post by Rudi De Vos »

Code has not yet been added to development, it a separated tree used to merge SC with 1.3.8.1
A lot of refactor...but indeed we already can create a 1.3.9 dev area for it as SC2.0 and 1.3.9 dev have the same source.

Still want to add some buildin ssh or/and a good p2p library, something more general the the repeater.
upotrebitel
Posts: 6
Joined: 2022-04-22 02:23

Re: Error in VNCViewer after ver.1.3.6.0

Post by upotrebitel »

Excuse me, but why my third post is still not approved by a moderator?
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6508
Joined: 2004-04-23 10:21
Contact:

Re: Error in VNCViewer after ver.1.3.6.0

Post by Rudi De Vos »

Done,
Sorry, a new viewer will not fix this server issue.
upotrebitel
Posts: 6
Joined: 2022-04-22 02:23

Re: Error in VNCViewer after ver.1.3.6.0

Post by upotrebitel »

OK, can I change configuration im my "options.vnc" file to aviod this server isue?
VNCHELP890
20
20
Posts: 32
Joined: 2022-01-18 16:46

Re: Error in VNCViewer after ver.1.3.6.0

Post by VNCHELP890 »

Is there a 1.3.9 area yet? Not sure if it would be linked from here.
Even if an empty "placeholder", it would indicate where to look in the future.
Thanks.
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6508
Joined: 2004-04-23 10:21
Contact:

Re: Error in VNCViewer after ver.1.3.6.0

Post by Rudi De Vos »

Found also a way to fix a viewer, so it can run with the old server.
upotrebitel
Posts: 6
Joined: 2022-04-22 02:23

Re: Error in VNCViewer after ver.1.3.6.0

Post by upotrebitel »

Tell me more about this way, please?
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6508
Joined: 2004-04-23 10:21
Contact:

Re: Error in VNCViewer after ver.1.3.6.0

Post by Rudi De Vos »

Use the new viewer with the old server

viewtopic.php?t=37597
Post Reply