1.3.8.2 online

Post Reply
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6533
Joined: 2004-04-23 10:21
Contact:

1.3.8.2 online

Post by Rudi De Vos »

bin 32/64 + IPv6
https://www.uvnc.eu/download/1382/UltraVnc_1382.zip

installers
https://www.uvnc.eu/download/1382/Ultra ... _Setup.exe
https://www.uvnc.eu/download/1382/Ultra ... _Setup.exe

dpi fix viewer (Thanks Thomas Levering)
sc_promt + sc_exit options where broken by the custom notification message.
upgrades are not alsways easy, new viewer can be used with old server.
Viewer 1.3.8.2 should work with 1.3.8.1 server
Server 1.3.8.2 should work with 1.3.8.1 viewer
Zeff
Posts: 2
Joined: 2022-05-07 10:08

Re: 1.3.8.2 online

Post by Zeff »

Hello Rudi,

many, many thanks for your upgrade 1.3.8.2 and for the IPv6-Binaries!
The "reverse connect" (sc prompt + sc_exit) problem has been fixed.
Reverse connects works well!

But please take a look in your ZIP-File "UltraVnc_1382.zip".
There are in the folder x64 two server files:
- winvnc.exe (version 1.3.8.2, only for IPv4)
- winvnc64.exe (version 1.3.9.1, only for IPv4)
I can't find the server file for IPv6.

In the folder x86 all files are completely contained.

Would it be possible to supply the missing file?

Andy
Thomas Levering
40
40
Posts: 83
Joined: 2015-01-23 06:45

Re: 1.3.8.2 online

Post by Thomas Levering »

Thank you :)

x64\winvnc64.exe is 1.3.9.1 in zip (is this winvncipV6.exe?) and the timestamp is from 24.04.2022
all other files are 1.3.8.2
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6533
Joined: 2004-04-23 10:21
Contact:

Re: 1.3.8.2 online

Post by Rudi De Vos »

winvnc64.exe wrong this should have been the IPv6 build

zip updated
VNCHELP890
20
20
Posts: 32
Joined: 2022-01-18 16:46

Re: 1.3.8.2 online

Post by VNCHELP890 »

Is this an "official" release? Not seeing it on the main page or the announcement page.
Thanks.
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6533
Joined: 2004-04-23 10:21
Contact:

Re: 1.3.8.2 online

Post by Rudi De Vos »

Yes it is, we decided to release the fixes in the 1.3.8 , this is an official release.
Usual the webpages are updated a few days later, to get some forum feedback to avoid stupid mistakes.

The 1.3.9 is the test branch.
When new stuff has been added to 1.3.9 it's merged with 1.3.8.x into 1.4.0...gonna take at least a few months more.
VNCHELP890
20
20
Posts: 32
Joined: 2022-01-18 16:46

Re: 1.3.8.2 online

Post by VNCHELP890 »

I think I've got it. Makes sense.

Will grab the 1.3.8.2 and start pushing that out to users. Heck, we still have users on 1.0.9.1, 1.1.9.6, 1.2.0.5, 1.2.1.2, 1.2.2.4, 1.2.4.0, and up! I try to update them as and when I can.
Last edited by VNCHELP890 on 2022-05-16 15:34, edited 1 time in total.
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6533
Joined: 2004-04-23 10:21
Contact:

Re: 1.3.8.2 online

Post by Rudi De Vos »

I really want to add some kind of cloud connect in 1.4, then you only need a code to connect to the server even when he is behind a nat router.
Takes a little time to implement.
If bugs popup, i just update 1.3.8
user8446
Posts: 4
Joined: 2022-01-23 18:00

Re: 1.3.8.2 online

Post by user8446 »

Hi,

Just reporting that I installed 1.3.8.2 x64 server via the installer in the link above and the clients fail to connect. The logs show an authentication issue so I put the VNC password back in but it still fails.

Downgrading back to 1.3.8.1 immediately works as expected.
Craig87
8
8
Posts: 13
Joined: 2018-08-27 18:34

Re: 1.3.8.2 online

Post by Craig87 »

Thanks for IPv6. Will this version be getting an MSI installer?
SkyBeam
40
40
Posts: 119
Joined: 2012-12-31 11:01

Re: 1.3.8.2 online

Post by SkyBeam »

I am having some regression issues with version 1.3.8.2:
  • UltraVNC Viewer 1.3.8.2 seems not to send the send the notification text (using -InfoMsg or viewer security tab text field
  • UltraVNC server 1.3.8.2 seems not to display the custom connect notification message (even when using viewer 1.3.8.1 which certainly is sending it as validated with 1.3.8.1 server)
Authentication used: Local password (no mslogon)
Encryption used: yes

Using version 1.3.8.1 on server and cliend side working fine.
Using version 1.3.8.2 on either server or client side does not work and message is ignored (=> viewer 1.3.8.2 does not send the message, server 1.3.8.2 does ignore the message if sent by viewer).

You did mention some issues with the new notification feature, but I did not expect them not to work any more at all. So forgive me if my interpretation was wrong and the feature is basically dropped again now. Currently I can't seem to get any notification message sent using Viewer 1.3.8.2 or Server 1.3.8.2 (or both versions equally at 1.3.8.2). But if the feature is dropped I am not sure why the text field is still in the viewer to enter a message and also the server properties still allowing me to configure when to show it. In fact it's showing the message if set to "always show" but only showing ID::... (or IP).
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6533
Joined: 2004-04-23 10:21
Contact:

Re: 1.3.8.2 online

Post by Rudi De Vos »

Damm.

Then i need to check it again, was to focussed to fix the sc_exit loop bug caused by sending the message.

Sorry
SkyBeam
40
40
Posts: 119
Joined: 2012-12-31 11:01

Re: 1.3.8.2 online

Post by SkyBeam »

Rudi De Vos wrote: 2022-05-31 21:15 Then i need to check it again, was to focussed to fix the sc_exit loop bug caused by sending the message.
No worries. It's not a mission-critical feature. I did not even roll back. So just great if it can be fixed for one of the upcoming releases (if you can reproduce the issue so I am not the only one having this problem).

Keep up the great work.

Thank you!
Juggler
Posts: 1
Joined: 2022-06-20 11:51

Re: 1.3.8.2 online

Post by Juggler »

winvncIPv6.exe runs, ipv6 option is not grayed out, but when enabled and clicked ok, is not saved. ipv6 is not working for some reason, nothing in the log
VNCHELP890
20
20
Posts: 32
Joined: 2022-01-18 16:46

Re: 1.3.8.2 online

Post by VNCHELP890 »

1.3.8.2 still the latest available?
Thanks.
Shadow Lord
8
8
Posts: 16
Joined: 2012-07-08 03:05

1.3.8.x problems with dual screen

Post by Shadow Lord »

Hello All,

I recently upgrade from 1.3.2.x to 1.3.8.1 (and subsequently to 1.3.8.2). For the most part everything seems to work fine except on connecting to some of the servers I don't get a screen.

Client System:

Win 7 x64 Fully Patched
UVNC Client 1.3.8.2


Server System 1:
Win 28KR2 Fully Patch
UVNC Server 1.2.2.3
NO ISSUES

Server System 2:
Win 7 SP1
UVNC Server 1.3.2.x (initially)
Try to connect with UVNC Client 1.3.8.1 and 1.3.8.2 and it looks like connection has failed. In reality connection is established, but no windows is displayed. However, if I uses ctrl-alt-f12 and go to full screen I can see the remote system ans everything works. Any attempt to go into a window mode causes the display to disappear. Tried upgrading the server to 1.3.8.1 and had the same results on connect. However, a second reboot seemsto have fixed the issue.

Server System 3:
Win 8.1
UVNC Server 1.3.2.x (initially)
Try to connect with UVNC Client 1.3.8.1 and 1.3.8.2 and it looks like connection has failed. In reality connection is established, but no windows is displayed. However, if I uses ctrl-alt-f12 and go to full screen I can see the remote system ans everything works. Any attempt to go into a window mode causes the display to disappear. Tried upgrading the server to 1.3.8.1 and had the same results on connect. I then upgraded the server to 1.3.8.2 and had the same results on connect. However, if I turn off dual displays the system will connect and display the window with the remote systems screen.

Server System 4:
Win 7 Fully Patched
UVNC Server 1.3.8.1 (fresh install)
No issues.

As you can see the problem expands multiple OSes, systems, and install scenarios. The only thing that seems to work reliably is disabling dual displays on the client system or running in full screen mode. Anyone else seeing this issue? Thanks.
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6533
Joined: 2004-04-23 10:21
Contact:

Re: 1.3.8.2 online

Post by Rudi De Vos »

Can you pm the ultravnc.ini ( remove passwd/ ip address) deom a server with the issue's.

What happen if you copy the full ultravnc folder from a working pc and run this on the bad pc ?
Shadow Lord
8
8
Posts: 16
Joined: 2012-07-08 03:05

Re: 1.3.8.2 online

Post by Shadow Lord »

Rudi De Vos wrote: 2022-09-18 12:15 Can you pm the ultravnc.ini ( remove passwd/ ip address) deom a server with the issue's.

What happen if you copy the full ultravnc folder from a working pc and run this on the bad pc ?
Sure, PM Sent. Please note that ALL of these systems have been working flawlessly together (i.e. the same client connecting to the same servers) for years without issues.I have not made any configuration changes on any of the systems other then upgrading UVNC.

The ultravnc.ini is from the Win 8.1 system which is consistently problematic. Thank you.
Post Reply