Update: UltraVNC 1.4.3.6 and UltraVNC SC 1.4.3.6: viewtopic.php?t=37885
Important: Please update to latest version before to create a reply, a topic or an issue: viewtopic.php?t=37864

Join us on social networks and share our announcements:
- Website: https://uvnc.com/
- GitHub: https://github.com/ultravnc
- Mastodon: https://mastodon.social/@ultravnc
- Facebook: https://www.facebook.com/ultravnc1
- X/Twitter: https://twitter.com/ultravnc1
- Reddit community: https://www.reddit.com/r/ultravnc
- OpenHub: https://openhub.net/p/ultravnc

UltraVNC 1.4.3.6 - Feedbacks

User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

UltraVNC 1.4.3.6 - Feedbacks

Post by Rudi De Vos »

Feedbacks for UltraVNC 1.4.3.6 and UltraVNC SC 1.4.3.6 (experimental) in this topic.

Announcement and Download links:
- viewtopic.php?t=37885
CPC
40
40
Posts: 64
Joined: 2010-10-08 15:31

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by CPC »

Hello
Tested SC 1.4.3.6 using this online creator https://support1.uvnc.com/cgi-bin/upload12.pl
I uploaded my helpdesk.zip with just helpdesk.txt and my Server_SecureVNC.pkey inside it.
The resulting exe was 1389KB. Detailed version info also correctly showed 1.4.3.6.

Reverse connection to provide tech support and do file transfers seems to be working well with what I used it for during 30 min session. Will test more.

As mentioned previously with SC 1.4.3.5 The UAC gets moved down to "never notify" upon running the SC and does not move back up to the users setting upon closing UVNC SC. Is there a way to have UVNC SC put the UAC back to where is was when it is closed??? (Many of the users requiring help via an SC connection, are the very type of challenged users that should have UAC at the default / warn level setting.) :-?

Thanks again for the great ultravnc program and contributions.
CPC
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by Rudi De Vos »

Retested SC
with
[DIS_AUC]

Just tested and the slider is down after connect and back up after disconnect.

Placed break points and function is indeed called on disconnect.
Work correct on 22H2 Windows 10, can't repeat it.
CPC
40
40
Posts: 64
Joined: 2010-10-08 15:31

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by CPC »

More behavior info on Testing UAC with SC 1.4.3.6... UAC is lowered to "never notify" upon connection.

If either side closes/disconnects the connection via the yellow winvnc icon in the taskbar... UAC remains at "Never Notify" after the session closes.

However, if the session is ended by the UltraVNC viewer's application and using the Red X from the viewer's menu .. UAC moves back to the proper setting after the session closes.

So in my win 10 / win 10 test... if I want to put UAC back once session closes... use the RED X from the viewers menu and not the yellow taskbar icon.

Let me know if this is by design and / or if you want more info.

Thanks Again
CPC
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by Rudi De Vos »

OK, that's another test then i did.
Gonna test it this way

Found and fixed
alexnts
Posts: 2
Joined: 2023-10-20 08:54

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by alexnts »

Hello,

the behavior of the msi switched is the same as 1.4.3.5
i quote
using the command above, the installer launches and expects to go though it manually.
The options seems to be selected from the parameters defined in the command above.
What is the expected behavior?
Best regards.
CPC
40
40
Posts: 64
Joined: 2010-10-08 15:31

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by CPC »

Hello Rudi

Feedback on SC UAC behavior... (same)

I re-created a test SC 1.4.3.6 on 10/23/2023 with the same UAC results using...
-secureplugin -connect myipaddres:5500 -noregistry
https://support1.uvnc.com/cgi-bin/upload12.pl
Windows 10.19045 to Windows 10.19045 with a 1.4.3.6 viewer.

Session seems to run fine.
If the session is ended via the UltraVNC viewer's application using the Red X from the viewer's menu .. UAC moves back to the proper setting after the session closes.

However, if the either side closes/disconnects the connection via the yellow winvnc icon in the taskbar...UAC remains at "Never Notify" after the session closes. (If by design, users should to be aware of this)

Thank you again
CPC
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by Rudi De Vos »

Updated
https://support1.uvnc.com/cgi-bin/upload12.pl

Looks that the behaviour was different in debug and release mode.
If A close faster then B, then A can't reactivate UAC.
Now manual added again to reactivate UAC when the tray close. Should work in all cases.

Please verify (SC has version 1.4.3.7)
CPC
40
40
Posts: 64
Joined: 2010-10-08 15:31

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by CPC »

Rudi...

Update UltraVNC Single Click version 1.4.3.7 UAC settings confirmed working :thumbs:

As of now the UAC behavior in UVNC SC 1.4.3.7 from https://support1.uvnc.com/cgi-bin/upload12.pl is working as expected.
Upon exiting the support session using either the toolbar red X or the yellow taskbar icon, the UAC moves back to its original setting.

So far in testing.... This is the best UltraVNC single click to date. For those that don't know ... At only 1.4MB with encryption, this is one of the simplest ways of providing remote helpdesk support to technically challenged users. There is no need for the person seeking help to change any firewall settings or install anything. There are no confusing questions, tricks, ads or malware in the default SC exe from the uvnc sc website. This is a great open source tool for providing support. *** Of course, as with any remote desktop tools, only use this program with someone you know and trust. If someone you don't personally know and trust is trying to get you to run any program... don't do it.

Rudi...Thanks again for contributing to a great product.
CPC
CPC
40
40
Posts: 64
Joined: 2010-10-08 15:31

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by CPC »

Hello everyone

Another option that would be nice in the single click version is a longer auto reconnect if the internet were to drop.

While providing support or doing updates to a network adapter the internet may drop or if for example the user has a bad / flaky internet connection and intermittently disconnects.

As a simple test ....if during a session I unplug the ethernet cable for just a few seconds and plug it back in... the remote session continues.
However, if I unplug the ethernet cable for longer then about 15 seconds and plug back in, the remote session ends and would need to call the person to run the SC exe again to get reconnected.

Just as an extra test messing around, I created another test SC exe with this in the file -secureplugin -autoreconnect -connect myipaddress:5500 -noregistry and the added "-autoreconnect" does not reconnect like in the normal full service version doing a reverse connection.

Is there is another command I can try for autoreconnect with the singleclick version?
(In the full service version of UVNC that I use daily, -autoreconnect works excellent with a reverse conenction, I am just wondering if the same can be done in the singleclick version... just in case others are looking to do this)

Thanks everyone.
CPC
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by Rudi De Vos »

winvnc SC is the same code as winvnc now.

I didn't tested if the command lines of winvnc also works with SC, i give it a 80% change it does.
You can try adding them as first parameters in the helpdesk.txt

All related the to service isn't working, this part is disabled for SC, we don't want an accidental service install.
CPC
40
40
Posts: 64
Joined: 2010-10-08 15:31

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by CPC »

Rudi.. Thank you for previous response regarding the online UVNC SC and not running in service mode intentionally. That makes sense.

(For those who really need a SC version with autoreconnect option, you can create our own custom single click type application using winvnc and 7-zip, that can be set to run in service mode and allow -autoreconnect. This isn't as easy as the great online creator here @ uvnc but it can be done and you risk some AV notification issues depending on what you do.)

??? ultravnc.ini ???
Another observation and maybe an update at some point in time to the uvnc website documentation is with regards to ultravnc.ini
When I compare ultravnc.ini from and older verison such as 1.3.8.2 to the newer version 1.4.3.6 there are a few newer entries as shown below.
MaxViewerSetting=0
MaxViewers=128
Collabo=0
Frame=0
Notification=0
OSD=0
NotificationSelection=0
ReverseAuthRequired=1
cloudServer=
cloudEnabled=0
etc.
When doing a search for "ultravnc.ini" and the "entries" in the list above, it is not easy to find information / documentation on them.

Thanks again... 1.4.3.6 server, viewer and SC working well in the time I have spent with them.
CPC
:thumbs:
MaXER
Posts: 1
Joined: 2023-10-27 05:08

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by MaXER »

Hi, two issues:
1. there is no vnc app found when I search through start in win11 pro on a domain.
2. 1.4.3.6 viewer can connect to a win11 pro 1.3.2 vnc but the reverse 1.3.2 viewer cannot see the 1.4.3.6 server

The 2nd issue holds me back on 1.3.2 version.
Thanks for any thoughts
elmernet
Posts: 3
Joined: 2011-08-03 16:05

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by elmernet »

I think there is a problem with authentication in this version 1.4.3.6.
I configured it to authenticate with MS Logon, on a 2012 r2 Domain Controller server, I used UVNC Group 1, it does not accept authentication.
With the right mouse button on the icon and going to settings, no matter how many adjustments I make again, it will always show the default configuration (default group already created)... however, if I go to start/programs and go to settings there , there it shows the configuration I made, but it doesn't work.
I reverted to version 1.3.8.1, it works very well here, a sign that I didn't do anything stupid and that I know how to configure this feature...

Thanks.
lwc
40
40
Posts: 90
Joined: 2006-08-08 11:00

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by lwc »

CPC wrote: 2023-10-20 21:51 As mentioned previously with SC 1.4.3.5 The UAC gets moved down to "never notify" upon running the SC and does not move back up to the users setting upon closing UVNC SC.
Is this only with [DIS_UAC]? If so, how did [DIS_UAC] work before?
CPC
40
40
Posts: 64
Joined: 2010-10-08 15:31

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by CPC »

lwc... Rudi commented he found the issue with UAC not returning to original setting....see Rudi's post 10-24-2023 10:26
It had to do with which method was used to close the viewer / speed
lwc
40
40
Posts: 90
Joined: 2006-08-08 11:00

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by lwc »

CPC wrote: 2023-11-06 21:32 lwc... Rudi commented he found the issue with UAC not returning to original setting....see Rudi's post 10-24-2023 10:26
It had to do with which method was used to close the viewer / speed
This was not what I asked. I was just asking if lowering it while using the control only happens if using [DIS_UAC], plus how did it work before v1.4.3.5?
CPC
40
40
Posts: 64
Joined: 2010-10-08 15:31

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by CPC »

@lwc With regards to my observation of the UAC behavior during a quick test of the online SC creator. I was using the default settings of the Single Click version generated by the online creator mentioned with no change or entry to [DIS_UAC]. (As in... default online creator with only my -secureplugin and ipaddress added to the .txt file.) I did not test the version prior to 1.4.3.5
lwc
40
40
Posts: 90
Joined: 2006-08-08 11:00

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by lwc »

But the default https://www.uvnc.eu/download/1400/helpdesk.zip already includes [DIS_UAC], meaning unless you manually removed it then you did use it.
CPC
40
40
Posts: 64
Joined: 2010-10-08 15:31

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by CPC »

@lwc To clarify ...There is nothing to solve for me with regards to the minor UAC observation I gave feedback on. default = default
I gave feedback on a UAC issue observed having to do with closing the default single click version of UVNC. Rudy found and confirmed the issue with UAC and he says he has solved the issue as indicated in his post on 10-24-2023 10:26. Done.

If you are trying to help me in someway, thank you very much. However, to be clear, there is no issue or problem that I am having or trying to resolve.

I pointed out a possible UAC security issue that users may have with SC and Rudy confirmed and solved it.

Thanks to all who contribute to UltraVNC
:D
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by Rudi De Vos »

Yep, it was a security issue that UAC was not restored.
[DIS_AUC] was working

The fix was for this security issue
lwc
40
40
Posts: 90
Joined: 2006-08-08 11:00

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by lwc »

I was just asking in general - did [DIS_UAC] always turn off UAC during the session (and restored it upon exit) or is it a new feature?

I'm not talking about the specific fix that affected restoring, but about the general feature.
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by Rudi De Vos »

Yes, on exit it should always restore the orig setting.
It was working like that with the old SC, but something went wrong merging the code in the full winvnc for the new SC
lwc
40
40
Posts: 90
Joined: 2006-08-08 11:00

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by lwc »

In that case what worries me is what if there's a sudden crush and then the very people that need UAC the most would be left without it...
Does the program at least have something like "on exit perform" that might still run in some crashes?
Not that it crashes a lot, but sometimes you might restart someone's computer while installing something remotely and then UAC might remain off.
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by Rudi De Vos »

Reboting would not be the problem, then all apps get the shutdown message and proper exit.
Pressing the power button... yes, no why to restore.

The only problem i can see is when sc itself crash, depending on the crash.
If the exception cause a shutdown like a incomplete tcp package then the restore is done.

Checking if i can't add a run once, then on reboot the old uac is also reset.
SkyBeam
80
80
Posts: 142
Joined: 2012-12-31 11:01

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by SkyBeam »

Rudi De Vos wrote: 2023-11-19 12:40 Checking if i can't add a run once, then on reboot the old uac is also reset.
You would have to create a scheduled task with SYSTEM privileges or a service. RunOnce is runing in login-user context (which might not have admin privileges).

Another idea: If SC is crashing and cannot revert UAC then usually the user is asked to re-start it to continue the support session. However on subsequent start SC might think "UAC is already off, so leave it off and on exit keep it on off". To avoid this SC might write the current state of UAAC (and its level) to the registry. If it finds a registry value on startup and current setting is different it should return to the stored value on exit and clean the saved value from the registry.
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by Rudi De Vos »

This is better
On restart old ( 0x5 ) value is restored

<nul set /p="N" | schtasks /create /TN SomeTaskName /TR "REG ADD HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System /v ConsentPromptBehaviorAdmin /t REG_DWORD /d 0x5 /f" /SC onstart /V1 /Z /RU "system"
Thomas Levering
40
40
Posts: 84
Joined: 2015-01-23 06:45

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by Thomas Levering »

Hello,

i found a small Problem.
If i save a Connection to *.vnc File with Password
The Password is not used if the first crypted char in the *.vnc File ist "00"

[connection]
..
password=0012345678901234

is not used


PS: I Generate a other Password
stefanorossetti
20
20
Posts: 49
Joined: 2018-11-23 09:48

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by stefanorossetti »

problem report:
SC 1.4.3.6 with Windows 7 often crashes after a few seconds of being connected. tested with windows 10 or 11 no problem. windows 7 only
freik
Posts: 3
Joined: 2024-01-12 10:20

Re: UltraVNC 1.4.3.6 - Feedbacks

Post by freik »

Neither 'https://sc.uvnc.com/downloads/single-cl ... loads.html' nor 'https://sc.uvnc.com/products/uvnc-sc/78 ... eator.html' SC Online Creator are operative, both replies and refresh same page or gets "connection has failed". Pls update Online Creator for SC. Thanx a lot :thumbs:
Post Reply