1.3.8.1 online

Post Reply
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6557
Joined: 2004-04-23 10:21
Contact:

1.3.8.1 online

Post by Rudi De Vos »

security fix

https://uvnc.com/downloads/ultravnc/150 ... 3-8-1.html

Short description
If a normal user install a fake plugin dll he could get admin access.
CVE-2022-24750
CPC
20
20
Posts: 54
Joined: 2010-10-08 15:31

Re: 1.3.8.1 online

Post by CPC »

Hello

1.3.8.1 32bit good so far. No negative surprises in my daily use case. (single click reverse connections app).

Thanks again for the update.
CPC
isidro
Posts: 4
Joined: 2017-11-18 01:17

Re: 1.3.8.1 online

Post by isidro »

Clipboard from remote machine can't be copied to local machine. (The opposite works). It looks like it also fails with old versions. Maybe some hidden config option?
Last edited by isidro on 2022-03-22 19:45, edited 1 time in total.
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6557
Joined: 2004-04-23 10:21
Contact:

Re: 1.3.8.1 online

Post by Rudi De Vos »

Anyone else have this ?
Remote to local clipbaord fail.
isidro
Posts: 4
Joined: 2017-11-18 01:17

Re: 1.3.8.1 online

Post by isidro »

Just installed (on both machines)older v1.2.40 and then v1.2.24 with same behaviour. I'm almost sure it worked before, but maybe I didn't noticed that bug. Will try it on other machines without previous installs. (Forgot to mention that this was tested on w7 64bits).
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6557
Joined: 2004-04-23 10:21
Contact:

Re: 1.3.8.1 online

Post by Rudi De Vos »

Try
remove ultravnc.ini, to reset to defaults, the installer doesn't remove the ini
ps: Yoy need to set the password(s) again.
Craig87
8
8
Posts: 13
Joined: 2018-08-27 18:34

Re: 1.3.8.1 online

Post by Craig87 »

Can you please enable IPv6 on the Viewer? Thanks.
newmann
Posts: 5
Joined: 2015-03-27 16:38

Re: 1.3.8.1 online

Post by newmann »

Hi Rudy, just to let you know that the x64 setup.exe installer is missing the logmessages.dll that should be installed in the program directory, this is causing errors in event viewer not to be displayed correctly. I don't think this is limited to this release I think it is not present in older installers.

The X86 and MSI appear to contain the file

Neil
VNCHELP890
20
20
Posts: 36
Joined: 2022-01-18 16:46

Re: 1.3.8.1 online

Post by VNCHELP890 »

newmann wrote: 2022-03-31 10:31 Hi Rudy, just to let you know that the x64 setup.exe installer is missing the logmessages.dll that should be installed in the program directory, this is causing errors in event viewer not to be displayed correctly. I don't think this is limited to this release I think it is not present in older installers.
Between the above fix, and this (from release notes), I wonder if a 1.3.8.2 would be forthcoming. Sorry, but I'm a bit of a perfectionist sometimes.
-Revert "update zipunzip 6.0"
-update zipunzip 6.0

No big deal, really, but if it causes less errors, and frustrates less people, why not?

Thanks.
Thomas Levering
40
40
Posts: 83
Joined: 2015-01-23 06:45

Re: 1.3.8.1 online

Post by Thomas Levering »

Viewer

Problem:
m_Dpi = GetDeviceCaps(GetDC(m_hwndMain), LOGPIXELSX);
sometimes give the wrong DPI
Laptop with 4k Boot, connect to dock(disconnet primary 4k and connect 2k display)
then GetDeviceCaps deliver 192 DPI (only 96 DPI Monitor connected)

Solution:
change GetDeviceCaps to GetDpiForMonitor

ClientConnection.h + ClientConnection.cpp (OneDrive)
https://1drv.ms/u/s!AkdsiVHAVCeBhjFMuxm ... T?e=U0Yig6


ClientConnection.h
#include "ShellScalingApi.h"

Line 137
namespace rdr { class InStream; class FdInStream; class ZlibInStream; class xzInStream; class ZstdInStream; }
typedef BOOL(WINAPI* PFN_GetDpiForMonitor) (HMONITOR, MONITOR_DPI_TYPE, UINT*,UINT*);
typedef BOOL(WINAPI* PFN_AdjustWindowRectExForDpi) (LPRECT, DWORD, BOOL, DWORD, UINT);

Line 846
UINT m_Dpi;
UINT m_DpiOld;
bool m_DpiMove;
HMODULE hShcore;
HMODULE hUser32;
PFN_GetDpiForMonitor getDpiForMonitor;
PFN_AdjustWindowRectExForDpi adjustWindowRectExForDpi;
public:


ClientConnection.cpp
Line 589
tbWM_Set = false;

hShcore = LoadLibrary(_T("Shcore.dll"));
if (hShcore)
// GetDpiForMonitor, Windows 8.1 [desktop apps only]
getDpiForMonitor = (PFN_GetDpiForMonitor)GetProcAddress(hShcore, "GetDpiForMonitor");
if (getDpiForMonitor)
{
HMONITOR monitor = MonitorFromWindow(m_hwndMain, MONITOR_DEFAULTTONEAREST);
UINT xScale, yScale;
getDpiForMonitor(monitor, MDT_DEFAULT, &xScale, &yScale);
m_Dpi = xScale;
}
else
{
m_Dpi = GetDeviceCaps(GetDC(m_hwndMain), LOGPIXELSX);
}
m_DpiOld = m_Dpi;
Cynyster
Posts: 1
Joined: 2022-04-04 13:16

Re: 1.3.8.1 online

Post by Cynyster »

Hello
I am attempting to use the /8greycolors switch and it does not seem to be working.
Remote sessions appear to be in full color.
I am attempting to connect to a system with a slow (5mbs upload) connection.

This functioned normally in 1.3.8 :-?

Thank you for your time.
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6557
Joined: 2004-04-23 10:21
Contact:

Re: 1.3.8.1 online

Post by Rudi De Vos »

Current refactoring the server.
Adding a settings manager and moving all settings to a single point in code.
SC_20 is partly done, need a settingsManager.

The i will check the dpi and 8colors later.
Zeff
Posts: 2
Joined: 2022-05-07 10:08

Re: 1.3.8.1 online

Post by Zeff »

First of all, thank you for the great program!
But unfortunately I have a problem with reverse connect.

Test environment in the LAN (without firewall)
Client A (server, 192.168.0.20) --> Client B (viewer, 192.168.0.11)

Program start viewer and server
Client B: vncviewer.exe -listen 12345
Client A: winvnc.exe -autoreconnect -connect 192.168.0.11::12345 -sc_exit -run

After starting the server on client A, the following error message appears
VncViewer Message Box
Server closed connection
- Manually closed
- Network disconn

The connect works fine with the VncViewer (Ver 1.3.7 dev-6).

@Rudy
Could you please also publish the IPv6 version because my LAN is from the
Internet only be reached via IPv6.

Zeff
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6557
Joined: 2004-04-23 10:21
Contact:

Re: 1.3.8.1 online

Post by Rudi De Vos »

scpromt has a conflict with the sending of a custom message that was added.
Require a fix.

Server was already fixed, but also want a new viewer that works with the 1.3.8.1 and new server.
VNCHELP890
20
20
Posts: 36
Joined: 2022-01-18 16:46

Re: 1.3.8.1 online

Post by VNCHELP890 »

Not seeing a 1.3.8.2 anywhere in the downloads area. Is this still a work in progress?
SkyBeam
40
40
Posts: 124
Joined: 2012-12-31 11:01

Re: 1.3.8.1 online

Post by SkyBeam »

VNCHELP890 wrote: 2022-06-08 13:40 Not seeing a 1.3.8.2 anywhere in the downloads area. Is this still a work in progress?
Version 1.3.8.2 is available in this thread.
However some issues were reported in regards to the new notification feature. I assume they will be addressed in an upcoming release soon.
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6557
Joined: 2004-04-23 10:21
Contact:

Re: 1.3.8.1 online

Post by Rudi De Vos »

I wanted to fix this first and then move to 1.3.8.3.
rvicker
Posts: 5
Joined: 2008-10-04 22:36

Re: 1.3.8.1 online

Post by rvicker »

Just setup a new system and GPO installed 1.3.8.1 from the stock MSI.
1) Did not associate *.vnc files.
2) Even with a manual association the viewer would not open them.
a) using a desktop shortcut to a shared *.vnc would get an Unable to Locate
b) Using a freshly created *.vnc on the local desktop would have the viewer immediately close without any display.
3) Reinstalled from the regular installer fixed the above.
lucius_the
Posts: 1
Joined: 2022-11-14 15:28

Re: 1.3.8.1 online

Post by lucius_the »

Zeff wrote: 2022-05-07 12:11 First of all, thank you for the great program!
But unfortunately I have a problem with reverse connect.

Test environment in the LAN (without firewall)
Client A (server, 192.168.0.20) --> Client B (viewer, 192.168.0.11)

Program start viewer and server
Client B: vncviewer.exe -listen 12345
Client A: winvnc.exe -autoreconnect -connect 192.168.0.11::12345 -sc_exit -run

After starting the server on client A, the following error message appears
VncViewer Message Box
Server closed connection
- Manually closed
- Network disconn

The connect works fine with the VncViewer (Ver 1.3.7 dev-6).

@Rudy
Could you please also publish the IPv6 version because my LAN is from the
Internet only be reached via IPv6.

Zeff
First off, would like to say A BIG thank you to Rudi for this great software. Been using it for years.
And yes. of course, I'm here because... problems :)

Just to confirm that I'm experiencing the exact same problem as above.
The problem seems to be in viewer. Viewer version 1.3.6 works ok, 1.3.8 breaks (with the message as above) then 1.3.9 dev5 seems to work again. Hope it helps. Regards and thank you
bwagoner17
Posts: 1
Joined: 2022-12-01 14:48

Re: 1.3.8.1 online

Post by bwagoner17 »

Good morning! I recently updated our image files and included the 1.3.8.1 version. Everything seemed to install properly, but when trying to contact my machine with the new version i get an error that the service is not installed. The only thing I changed in my scripting was the file name and the old versions have worked well for a long time. Curious if there are new command line options I should be using instead?

Here is the error:

Installing UVNC server...

The service name is invalid.

More help is available by typing NET HELPMSG 2185.

[SC] OpenService FAILED 1060:

The specified service does not exist as an installed service.

The system cannot find the file specified.
1 files copied



Here are my two different scripts. New first. Old second.
@echo off
cls
echo Installing UVNC server...
echo.
%~dp0UltraVNC_1_3_81_X64_Setup.exe /silent /loadinf=%~dp0config.ini
net stop uvnc_service
sc config uvnc_service start=demand
rd "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\UltraVNC" /S /Q
copy %~dp0ultravnc.ini "C:\Program Files\uvnc bvba\UltraVNC\" /Y
pause
exit

@echo off
cls
echo Installing UVNC server...
echo.
%~dp0UltraVNC_1_3_60_X64_Setup.exe /silent /loadinf=%~dp0config.ini
net stop uvnc_service
sc config uvnc_service start=demand
rd "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\UltraVNC" /S /Q
copy %~dp0ultravnc.ini "C:\Program Files\uvnc bvba\UltraVNC\" /Y
exit
Post Reply