Update: UltraVNC 1.4.3.6 and UltraVNC SC 1.4.3.6: viewtopic.php?t=37885
Important: Please update to latest version before to create a reply, a topic or an issue: viewtopic.php?t=37864

Join us on social networks and share our announcements:
- Website: https://uvnc.com/
- GitHub: https://github.com/ultravnc
- Mastodon: https://mastodon.social/@ultravnc
- Facebook: https://www.facebook.com/ultravnc1
- X/Twitter: https://twitter.com/ultravnc1
- Reddit community: https://www.reddit.com/r/ultravnc
- OpenHub: https://openhub.net/p/ultravnc

UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Locked
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by Rudi De Vos »

Feedbacks for UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 (experimental) in this topic.

Announcement and Download links:
- 1.4.3.1: viewtopic.php?t=37831
- 1.4.3.0: viewtopic.php?t=37825
SkyBeam
80
80
Posts: 142
Joined: 2012-12-31 11:01

Re: 1.4.3.0

Post by SkyBeam »

I did some tests with this version and so far I did not come across blocking issues for me.

One potential bug I spotted:
  • The sharing indicator frame around shared screen is not shown even when enabled in admin settings. OSD seems to work however if I enable to show notification as OSD. But the frame does not appear.
EDIT: Don't know how to say but I was sure I have restarted UVNC server multiple times and did not see the red frame. After connecting with no user logged in (to test file transfer, see below) the frame appeared and now is reliably shown when connecting. So I cannot reproduce the issue any more.


Quickly tested file transfer too which worked fine for me at least when a user is logged in.
When logging out all users no file transfers are possible but this behavior was explained in another thread as UVNC cannot know which credentials to apply as it uses the one of the logged-on user. I was just wondering if potentially the permissions of the VNC authentication user could be used in such case - at least if mslogon authentication is used where the remote connection is using a local authentication. This would of course not work for built-in VNC authentication as there is no mapping to a local Windows user account. But it would work if mslogon is selected.
However it would yield the question if the impersionation should change to the logged on user as soon as one is logged on and only use the mslogon username when no user is logged on (as a fallback) or always the mslogon user should be used (as it is the one the client essentially uses to authenticate to the server). I would personally prefer to use the currently logged on user credentials when available and fallback to mslogon user when none is available as users might rather expect to get access to the same files as the user they are remotely controlling regardless of the authentication credentials of VNC.

But I see no security issue right now if all users are logged out to use the credentials of the mslogon authenticated account. As in many cases it would also be possible to log on to the system using the very same account (known to the client). In my specific case I admit the user does not have permissions to log on and it's only used for VNC authentication and also it does not have admin credentials. So essentially I could use "guest" file transfer on logon screen.

Also another thing I noticed on a recent session: If multiple users are logged on to the same system (ie use fast user switching) VNC does not allow me to use file transfer in all user context as it seems to "stick" to one of them. So when logging on with one user I can use file transfer and when I switch to another user context and re-connect then UVNC file transfer will tell me that permissions are disabled. So I guess there might be a problem impersonating to the currently active user and the inactive one cannot be used.
As a work-around I need to log off all other users so I can use file transfer on the active desktop again.
user8446
Posts: 7
Joined: 2022-01-23 18:00

Re: 1.4.3.0

Post by user8446 »

Hi just letting you know all of those d/l links are timing out.
user8446
Posts: 7
Joined: 2022-01-23 18:00

Re: 1.4.3.0

Post by user8446 »

Update: just letting you know it was timing out for me because those links point to uvnc.eu instead of uvnc.com and uvnc.eu resolves to 213.186.33.4 which is on a blocklist for malware hosted at that IP
lwc
40
40
Posts: 90
Joined: 2006-08-08 11:00

Re: 1.4.3.0

Post by lwc »

user8446 wrote: 2023-06-28 22:47 Update: just letting you know it was timing out for me because those links point to uvnc.eu instead of uvnc.com
Normal links were later added to the actual website at https://uvnc.com/downloads/ultravnc.html
Rudi De Vos wrote: 2023-06-25 19:45 1.4.3.0
-balloon fix
Have to say [BALLOON2C] is still not presented in at least Windows 10.
ddbivens
80
80
Posts: 132
Joined: 2015-12-26 14:53
Location: Tellico Plains, TN 37385 USA

Re: UltraVNC 1.4.3.0 and UltraVNC SC 1.4.3.0 - Feedbacks

Post by ddbivens »

I know it is only cosmetic, but the UltraVNC_1431_X64.msi installer shows "UltraVnc 1.4.2.0 X64" during the first part of the setup process. I did not test the x86 msi installer. I downloaded the 1.4.3.1 installers tonight. Normally I don't install using the MSI installer but I launched the 64bit MSI installer by accident tonight.
ddbivens
80
80
Posts: 132
Joined: 2015-12-26 14:53
Location: Tellico Plains, TN 37385 USA

Re: UltraVNC 1.4.3.0 and UltraVNC SC 1.4.3.0 - Feedbacks

Post by ddbivens »

I am working remotely from home so this is just a first look. I setup the new installers at work around 10 hrs ago to begin installing/updating on PC reboot/login. There have been about 20 or so installs of this version of UltraVNC. The results are good! Very Good!!! Connections are fast and the screen draw is immediate. No more gray screens (haven't seen them for a while). This is another great release. Thank you for all your excellent work.
Ludovic
Super-Mod
Super-Mod
Posts: 45
Joined: 2021-12-28 18:55

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by Ludovic »

UltraVNC 1.4.3.1 and UltraVNC SC 1.4.3.1 Released:
- viewtopic.php?t=37831
Nanobot
8
8
Posts: 12
Joined: 2019-03-06 20:44

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by Nanobot »

I installed 1.4.3.0 on several PCs without problems and will update them to 1.4.3.1 in the next days.

But one question: Can we get an IPv6 enabled version please ? Or is it already available an I missed something ?
VNCHELP890
40
40
Posts: 69
Joined: 2022-01-18 16:46

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by VNCHELP890 »

  • I have 7 of the little square icons with the eyeball showing under the ^ down near the clock. Does that mean it is trying to start or what?

    Also, on one workstation I was remoting into, it had very strange graphics, greatly zoomed in, and all over the place. I am wondering if I installed this update over a much older version and things were not cooperating. If it comes up again, I will visit that computer in person and do a full uninstall/reinstall.

    Final issue is we still use Spiceworks inventory here, and it is not showing the proper version number there. I think it either comes in as 1.4.2.0 or 1.4.3.0 and not 1.4.3.1.
Thanks.
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by Rudi De Vos »

This mean that the server stopped unexpected.
Running as service the service start a new instance, but the tray doesn't cleanup until you hover over it.

It could be caused by a FileTransfer bug.
The server to stop unexpected after you disconnect the viewer and have used FT.
Already fixed...for next update
VNCHELP890
40
40
Posts: 69
Joined: 2022-01-18 16:46

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by VNCHELP890 »

Rudi De Vos wrote: 2023-07-31 16:14 This mean that the server stopped unexpected.
Running as service the service start a new instance, but the tray doesn't cleanup until you hover over it.

It could be caused by a FileTransfer bug.
The server to stop unexpected after you disconnect the viewer and have used FT.
Already fixed...for next update
Is that version available anywhere? Is the fix for the client side or the server side, or both? If the client side, I would download and put on my PC, as I am usually the "client", going into other computers acting as "server".

Thanks.
ddbivens
80
80
Posts: 132
Joined: 2015-12-26 14:53
Location: Tellico Plains, TN 37385 USA

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by ddbivens »

UltraVNC 1.4.3.1: I did some testing today on what we call the 'big green eye". We actually use it quite a bit and did not realize it was not working as expected. The target PCs were Windows 10/32bit and 64bit and Windows 11/64bit, and the viewer was running on a Windows 10/64bit PC. Connect while the remote user is logged off and activate the eye. The eye is on. Log the user on. The eye goes away. The local indicator shows it is still active. Toggle the eye off/on and the eye is active. Log the user off/on and the eye stays active, unless there is a temporary disconnect and the eye goes away. The local indicator shows the eye is active. Toggle the eye off/on and the eye is active. Disconnect from the remote PC. Obviously the eye goes away. Connect and activate the eye. Log the user on and the eye goes away. The local indicator shows it is still active. Toggle the eye off/on and the eye is active. Connect to a PC where the user is logged on but the desktop is locked and activate the eye and the PC shows a black monitor (not the eye). Unlock the user and the black monitor goes away. The local indicator shows the eye is still active. Disconnect/Reconnect/Toggle the eye off/on and you get a black monitor (not the eye). It appears you have to log the user off to reset the eye to be an eye and not a black monitor. The mouse pointer was visible on the remote PC whether the eye was showing or not or a black monitor was showing or not. (I know I repeated some stuff above, but it seems to matter if the user is logged off/on or if the desktop is locked/unlocked when I connect to the remote PC as to how the 'eye' behaves.
ddbivens
80
80
Posts: 132
Joined: 2015-12-26 14:53
Location: Tellico Plains, TN 37385 USA

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by ddbivens »

I found one other thing today about the 'eye'. When the monitor is black, if I click the "Start" button, that menu, options, icons all show on the remote PC, on an otherwise black monitor. If I launch a program, the launched program is not visible (hidden behind the black monitor).
jBart
8
8
Posts: 8
Joined: 2017-03-19 14:49

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by jBart »

I have severe problem with SC.
On Win7 with classic UI (that looks like WinMe) SC-UI shows only fragments.
Here SC sits a bit over the right side of explorer window
Image

This is with standard Win7-UI, but still not ok:
Image

This older versions of SC shows everything correctly.
How do I achieve that with the new SC?
Image

I created Sc with https://support1.uvnc.com/cgi-bin/upload12.pl
Is this correct?
Where can I find detailed documentation about the parameters, I only found it for older version. So using the new version is extremely difficult.
ddbivens
80
80
Posts: 132
Joined: 2015-12-26 14:53
Location: Tellico Plains, TN 37385 USA

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by ddbivens »

I found one other thing today about the 'eye'. When the monitor is showing the 'big green eye', if I click the "Start" button, that menu, options, icons all show on the remote PC, even when the eye is displayed. If I launch a program, the launched program is not visible (hidden behind the eye).
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by Rudi De Vos »

The 'eye' or your own image when putting a background.bmp in the folder is just a window with top highest zorder, always on top.

We can prevent that other application want to be on top, we only can put our own back.
The result is that you see a flash of the window, mouse.

Sorry, technical it isn't possible
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by Rudi De Vos »

SC, do you mean opening the app and it's local bad or remote ?

Seems that the background is messing up..without all is ok.
Please confirm that there is a custom background issue on win7, if background.bmp does not exist no custom background is used.
ddbivens
80
80
Posts: 132
Joined: 2015-12-26 14:53
Location: Tellico Plains, TN 37385 USA

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by ddbivens »

Just some quick input. I know that I am jumping a little fast, but I downloaded the file: winvnc._totest.zip and put it on my PC, here at home. I used the standard procedure of running winvnc.exe -stopservice (as Admin), renaming the old and new winvnc.exe files then running winvnc.exe -startservice (as Admin). I tried several times but it appears the new winvnc.exe does not recognize the -stopservice and -startservice commands. I rolled back to the previous version.
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by Rudi De Vos »

The totest was some SC version used to test win7 ... that doesn't have a service.

I will make this week a dev update with latest changes in 1.4.3.2-dev.

------------------

UltraVNC 1.4.3.2-dev:
- https://uvnc.eu/download/1430/UltraVNC_ ... _Setup.exe
- https://uvnc.eu/download/1430/UltraVNC_ ... _Setup.exe

Changelog since the previous stable build:
1.4.3.2-dev
- Can not FT folders fix
- Harden screen size, eliminate to smaal/big sizes
- FT crash server when viewer exit fix
- Query: show viewer message
- Log: viewer message is also logged in mslogon and event
jBart
8
8
Posts: 8
Joined: 2017-03-19 14:49

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by jBart »

The totest was some SC version used to test win7 ... , that doesn't have a service.
Where can I download that? I don't see a url.
VNCHELP890
40
40
Posts: 69
Joined: 2022-01-18 16:46

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by VNCHELP890 »

jBart wrote: 2023-08-11 17:53
The totest was some SC version used to test win7 ... , that doesn't have a service.
Where can I download that? I don't see a url.
Seconded!
Ludovic
Super-Mod
Super-Mod
Posts: 45
Joined: 2021-12-28 18:55

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by Ludovic »

MSOiD
Posts: 6
Joined: 2023-03-07 12:27

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by MSOiD »

-Query: show viewer message
Unfortunately this still doesn't work, it's even worse than before.
When you try to connect, put your password in, VNC Viewer Status shows password accepted, although on server side you don't get any pop up to accept. Then after few seconds on viewer side you get 'Your connection has been rejected' info and status: Connection closed(1)

After every connection there is also error in Windows Event Viewer:
WinVNC.exe
1.4.3.2
64cffe67
unknown
0.0.0.0
00000000
c0000005
0000000000000000
1508
01d9d0eeb4c00b7d
C:\Program Files\uvnc bvba\UltraVNC\WinVNC.exe
unknown
c6d95730-cb55-4d09-8b2b-2bb40664741d

All works fine if Notification on connect is left empty in viewer security tab.

Tested on 2 Windows 10 Pro laptops, hope that you can repeat and solve this issue.
Thanks.
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6828
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by Rudi De Vos »

old logging.dll was included...and new function require new dll
Will make an update, already uploaded correct dll's

https://www.uvnc.eu/download/1430/logging.zip
Ludovic
Super-Mod
Super-Mod
Posts: 45
Joined: 2021-12-28 18:55

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by Ludovic »

There is a UltraVNC 1.4.3.3-dev here:
- viewtopic.php?t=37855
Ludovic
Super-Mod
Super-Mod
Posts: 45
Joined: 2021-12-28 18:55

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by Ludovic »

There is a UltraVNC 1.4.3.4-dev here:
- viewtopic.php?t=37863

Please do the update, test and comment in specified topic.
Ludovic
Super-Mod
Super-Mod
Posts: 45
Joined: 2021-12-28 18:55

Re: UltraVNC 1.4.3.0/1.4.3.1 and UltraVNC SC 1.4.3.0/1.4.3.1 - Feedbacks

Post by Ludovic »

There is a UltraVNC 1.4.3.5 (stable) and UltraVNC SC 1.4.3.5 (experimental) here:
- Announcement: viewtopic.php?t=37866
- Feedbacks: viewtopic.php?t=37863

Please do the update, test and comment in specified feedback topic.
Locked