Update: UltraVNC 1.4.3.6 and UltraVNC SC 1.4.3.6: viewtopic.php?t=37885
Important: Please update to latest version before to create a reply, a topic or an issue: viewtopic.php?t=37864

Join us on social networks and share our announcements:
- Website: https://uvnc.com/
- GitHub: https://github.com/ultravnc
- Mastodon: https://mastodon.social/@ultravnc
- Facebook: https://www.facebook.com/ultravnc1
- X/Twitter: https://x.com/ultravnc1
- Reddit community: https://www.reddit.com/r/ultravnc
- OpenHub: https://openhub.net/p/ultravnc

UltraVNC 1.4.3.5 - Feedbacks

Locked
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6847
Joined: 2004-04-23 10:21
Contact:

UltraVNC 1.4.3.5 - Feedbacks

Post by Rudi De Vos »

Feedbacks for UltraVNC 1.4.3.5 and UltraVNC SC 1.4.3.5 (experimental) in this topic.

Announcement and Download links:
- viewtopic.php?t=37866
User avatar
Slovak9
Posts: 1
Joined: 2023-09-27 13:17

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by Slovak9 »

Could not find what I was looking for in a search of this forum, so I will ask my questions.
I have a customer who needs an app to be used to remote into various devices. I did a Google search and I searched this forum and I could not find any results.
Here are my customer's requirements:
Remote app needs to be able to control mobile devices.
Remote app needs to be able to connect to computers over the Internet that are NOT connected to the company's internal network.

His last requirement was met, he needs a remote app that can control Macs and Windows PCs.

Thank you
Slovak
Craig87
8
8
Posts: 17
Joined: 2018-08-27 18:34

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by Craig87 »

I can't seem to get "UltraVNC_1435_X64.msi" to install the service. Does anyone else have an issue?

MSI Log:
https://pastebin.com/DCCERDNE

Edit:
Looks like the custom actions for the MSI look for the property SERVER=1. I changed this to (SERVERVIEWER=1 Or SERVERVIEWER=3) and it attempts to install the service but I may be missing other things that need updating.
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6847
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by Rudi De Vos »

new msi is documented on the
Announcement and Download links page
- viewtopic.php?t=37866

.MSI commandlines:

SERVERVIEWER:

Code: Select all

SERVERVIEWER
1 server
2 viewer
3 server + viewer
SERVICE:

Code: Select all

SERVICE
1 install
2 not install
SAMPLE:

Code: Select all

UltraVNC_1435_X64.msi SERVERVIEWER=2 -> Install only Viewer
Craig87
8
8
Posts: 17
Joined: 2018-08-27 18:34

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by Craig87 »

Yes, I seen the MSI properties on that page, and used them.

I used:
SERVERVIEWER=3 SERVICE=1

I'm telling you that the service doesn't get installed as the Custom Action that installs the service is looking for SERVER=1.
VersusBG
Posts: 4
Joined: 2021-12-16 09:01

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by VersusBG »

I can confirm that the UltraVNC_1435_X64.msi installer doesn't register uvnc_service as service.
The "UltraVNC_1435_X64_Setup.exe" is working fine but not the .msi package.
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6847
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by Rudi De Vos »

will check

correct, forgot to replace the old value, done , updated git
Craig87
8
8
Posts: 17
Joined: 2018-08-27 18:34

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by Craig87 »

Ok thanks.

For anyone wanting to use the 1.4.3.5 MSI, this should work:

Code: Select all

UltraVNC_1435_X64.msi SERVERVIEWER=3 SERVICE=1 SERVER=1
VersusBG
Posts: 4
Joined: 2021-12-16 09:01

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by VersusBG »

Yes but if you uninstall it after the MSI installation the service is not deleted and you need to run:

Code: Select all

sc delete uvnc_service
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6847
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by Rudi De Vos »

Issue found and corrected.
Msi was changed for the commandline but forgot to update the install/uninstall.
Also msi had the option to not remove the old version checked, also changed to remove.

Committing to git
lwc
40
40
Posts: 90
Joined: 2006-08-08 11:00

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by lwc »

Help! With this version using SC I get your connection has been rejected (both with repeater and directly).
This has never happened before, what can be done?
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6847
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by Rudi De Vos »

checking plugin issue
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6847
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by Rudi De Vos »

Seems latest plugin doesn't like the be embedded.
For now added back the previous plugin.

https://uvnc.eu/download/1430/UltraVNC_SC_1436.zip
CPC
40
40
Posts: 64
Joined: 2010-10-08 15:31

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by CPC »

Hello Rudy

Some feedback
(I'm still using 1382 viewer in my daily work... and its working great)

I used this SC 1436 to create a single click UVNC just to test and give feedback
Using your earlier post https://uvnc.eu/download/1430/UltraVNC_SC_1436.zip
Then used this website to create my sc exe
https://support1.uvnc.com/cgi-bin/upload12.pl
((( Is this the latest site to use to create SC or is there something else I should test with??? )))
-secureplugin -connect myipaddress:5500 -noregistry
and I added my Server_SecureVNC.pkey
and after uploading my zip received my SC helpdesk.exe file at 1389KB in size

Tested and the single click exe works and is encrypted. (also file transfer and the features I tested worked.)

Observations...
Upon running ... I noticed that the UAC (user account control) was decreased to "Never notify" for the user who ran the SC exe.
When exiting the SC session the UAC remained at "Never notify" instead of going back up to where it was prior to the session.
This may be a known issue. I did not search the forum on this subject and just wanted to include it as feedback for this version.

Another small minor observation... your file says uvnc_sc_1436 but if you go into its properties is shows at 1.4.3.5 10/16/2023

Thanks for your continued work on a great product.
CPC
Last edited by CPC on 2023-10-20 01:00, edited 2 times in total.
lwc
40
40
Posts: 90
Joined: 2006-08-08 11:00

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by lwc »

Rudi De Vos wrote: 2023-10-16 19:12 Seems latest plugin doesn't like the be embedded.
For now added back the previous plugin.

https://uvnc.eu/download/1430/UltraVNC_SC_1436.zip
Which plugin? Could you release this as another version or at least update the online generator so it'll be with a signature, etc.?
Thanks!
User avatar
Rudi De Vos
Admin & Developer
Admin & Developer
Posts: 6847
Joined: 2004-04-23 10:21
Contact:

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by Rudi De Vos »

1.4.3.6 is for the weekend, then all files get proper updated, new msi etc...
Craig87
8
8
Posts: 17
Joined: 2018-08-27 18:34

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by Craig87 »

Ok thanks. :thumbs: Please include new IPv6 exe's.
tihabil
Posts: 4
Joined: 2017-12-02 02:12

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by tihabil »

Hi ,
First of all I want to say a big thank you for your work and dedication wich result in a such great utility.
I hope to help you providing my experience:

UVNC 1.4.3.5 after upgrade from 1.4.3.1 : first 1-2 seconds -Password requested- then -server closed connection- messages

The same OS and the same settings worked on UVNC1.4.3.1 but not, after upgrade UVNC to 1.4.3.5 version.

Then I tested a fresh installation of UVNC1.4.3.5 in a clean VM with W10 x64 Enterprise, up to date system but not worked while encryption was enabled. I tested Loopback connection and form an other PC in same LAN, with/without SecureVNCPlugin64 option. With Encryption SecureVNCPlugin64 option disabled, worked. I tried to use the previous Encryption plugin with 1.4.3.5 version of UVNC, and worked.
---------------------------------------------------------------------------------------------
alexnts
Posts: 2
Joined: 2023-10-20 08:54

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by alexnts »

Craig87 wrote: 2023-10-05 09:15 Ok thanks.

For anyone wanting to use the 1.4.3.5 MSI, this should work:

Code: Select all

UltraVNC_1435_X64.msi SERVERVIEWER=3 SERVICE=1 SERVER=1
Hello!
using the command above, the installer launches and expects to go though it manually.
The options seems to be selected from the parameters defined in the command above.

Is there a way to use the msi with the parameters as above but finish the installation silently?

I want to use the msi in a GPO, without a script, using only the parameters
Normal msi installation.


P.S. Are there options i can define using orca, i order to create a mst tranform file?
i only need to configure the path, installation of only the server, and to do not create shortcuts.

Best regards.
Last edited by alexnts on 2023-10-20 09:22, edited 1 time in total.
Ludovic
Super-Mod
Super-Mod
Posts: 50
Joined: 2021-12-28 18:55

Re: UltraVNC 1.4.3.5 - Feedbacks

Post by Ludovic »

Dear all,

Can you test the 1.4.3.6 before announcement?

Please go here:
- viewtopic.php?t=37883

Thanks in advance.
Locked